LDAP Integration


1 comment

  • Avatar
    Candido Dessanti

    Hi @mixhali,

    Welcome to the community forum.

    Taking a quick look at your configuration, it looks like the parameter.

    ldap-role-query-regex = “(Omniscius.*?),”

    It has a wrong value, so I can't get how the roles can get correctly detected.

    Have you tried to run the curl command suggested on docs?

    curl --user "uid=kiran,cn=users,cn=accounts,dc=mycompany,dc=com" 

    and the process the results with SED or a similar command to see if the Regex expression match your role names

    I cannot try the entire environment right now, but using this filter.

    ldap-role-query-regex = (Omnisci.*?),

    Assuming the roles are called Omnisciusers and Omniscisuper, it's going to match both when I tried with regex101.


    I will try to reproduce everything asap, in the meanwhile could you post the logfile


    As suggested into the documentation?

    Regards, Candido

    p.s. Are you using the Free Edition of tìout Software?

    Comment actions Permalink

Please sign in to leave a comment.