Lack of GPU Memory



  • Avatar
    Chris Root


    Thanks for the info you provided. It helps to answer your question.

    The first thing you're going to want to do is adjust your omnisci_server configuration file to account for additional gpu memory use by other processes. You can do this via the "res-gpu-mem" configuration flag (

    From your nvidia-smi output, it looks like there's approx 400MB of additional gpu mem being used by other processes. You're probably going to want to set "res-gpu-mem" to something higher than that to account for potentially other processes, and other residual gpu mem used by omnisci_server.

    I'd say set that to something like 700MB - 1GB.

    Also, you may not require the full 1GB of memory that the "CUDA_ERROR_UNKNOWN/CUDA_ERROR_NOT_SUPPORTED, possibly not enough gpu memory available for the requested buffer size of 1000000000 bytes on gpu 0." error refers to. The 1GB of memory requested here is controlled via the "render-mem-bytes" configuration parameter. You may want to try setting that lower depending on your use case if you're still crammed for memory.

    You can try setting that to 500MB as well.

    So, in summary, try adding:

    res-gpu-mem = 700000000

    and optionally: render-mem-bytes = 500000000

    to your server config file and restart the server.

    Comment actions Permalink
  • Avatar
    Gianfranco Campana

    Thank you Christopher, those two params solved the issue for some additional editing, but then the problem raised again:

    Chart Redraw Error warning_outline Exception: OutOfGpuMemoryError: Cuda error code=801, CUDA_ERROR_UNKNOWN/CUDA_ERROR_NOT_SUPPORTED, possibly not enough gpu memory available for the requested buffer size of 500000000 bytes on gpu 0.

    I still have to complete this dashboard, and I'm a bit concerned about the memory lacking: I have built rich and complicated dashboards with a old version of MapD on the same hardware, I find strange that this simple one already suffers from memory lacking on Omnisci.

    Comment actions Permalink
  • Avatar
    Candido Dessanti

    Hi @Gianfranco_Campana,

    In versions of omnisci prior to 4.0, the Choropleth map was a client-side object (You can get the same object starting the server in CPU mode), so it didn't take a single byte of GPU memory, while now it's rendered on the server, so we had to allocate a certain amount of memory to render this map.

    probably the software allocated too much memory to render your map, but we are constantly improving the software so the tunable parameters,


    Comment actions Permalink

Please sign in to leave a comment.